找回密码
 免费注册

际人学长的MACD红绿柱面积公式(飞狐指标)

0
回复
73
查看
[复制链接]

22

主题

23

帖子

200

积分

超级版主

Rank: 8Rank: 8

积分
200
来源: 2020-6-10 22:46:43 显示全部楼层 |阅读模式
input:调整参数(0.1,0.0001,1000),数字位置(1,1,1000);//{input:默认参数,最小值,最大值}



  1. p:=26;s:=12;m:=9;
  2. DIFF:EMA(c,s) - EMA(c,p);
  3. DEA:EMA(DIFF,m);
  4. MACD:2*(DIFF-DEA),COLORSTICK;
  5. BV:=SUM(MACD/调整参数,0);
  6. BA:=IF(MAX(BV,REF(BV,2))REF(BV,1),1,0);
  7. BC:=BARSLAST(BA)+1;
  8. SMACD:=BV-REF(BV,BC);
  9. 涨面积:=FLOOR(SUM(MACD,BARSLAST(MACD<0))/调整参数),linethick0;
  10. 跌面积:=FLOOR(ABS(SUM(MACD,BARSLAST(MACD>0)))/调整参数),linethick0;
  11. var3:=if(macd>0,HHV(abs(macd),bc)*数字位置,LLV(macd,bc)*数字位置);
  12. var4:=(macd)/20;{图形比例缩小1/20,可修改}
  13. var5:=SMACD*100;
  14. DRAWNUMBER(CROSS(0,MACD),ref(var3,1),REF(涨面积,1),0),,colorgreen;
  15. DRAWNUMBER(CROSS(MACD,0),ref(var3,1),REF(跌面积,1),0),colorff00ff;
  16. M1:=REF(MACD,1);
  17. STICKLINE(macd>0 and macd<=m1,0,macd,3,0),coloryellow;
  18. STICKLINE(macd<0 and macd>=m1,0,macd,3,0),colorwhite;
  19. jc := dea-diff;
  20. 绿柱面积:IF (MACD<0,SUM(MACD,BARSLAST(jc<0))/调整参数,0),linethick0,colorcyan,PRECISION0;
  21. 红柱面积:IF (MACD>0,SUM(MACD,BARSLAST(jc>0))/调整参数,0),linethick0,colorred,PRECISION0;

  22. AA1:=IF(MACD>0,1,-1),LINETHICK0;
  23. AA2:=REF(AA1,1),LINETHICK0;
  24. AA3:=AA1*AA2,LINETHICK0;
  25. AA4:=BARSLAST(AA3<0),LINETHICK0;
  26. AA5:=AA4+1,LINETHICK0;
  27. 当前面积:SUM(MACD,AA5)/0.10,COLORGREEN,LINETHICK0;
复制代码



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 免费注册
电话咨询: 135xxxxxxx
关注微信