找回密码
 免费注册

[文华源码] [转载]文华财经赢顺MACD面积公式

0
回复
95
查看
[复制链接]

22

主题

23

帖子

200

积分

超级版主

Rank: 8Rank: 8

积分
200
来源: 2020-6-10 22:45:47 显示全部楼层 |阅读模式
注:这个公式是用在欧美
外汇
上的,本身值才1.1218左右,绿柱面积和红柱面积值偏小,所以我在面积那里乘了参数1000,如果是用在大盘或者
美元
指数,显然自己需要调这个参数。
% ?2 i  ?  }: B( t  N1 Z! q

' E* z6 S$ C% Y9 J* n

1、柱堆的根数 T (组成这柱堆面积的根数)
$ ]$ W& o/ R1 {8 p9 l+ M% ]

2、速度 U (U=柱堆面积/T)
  t) d1 R/ W" M$ j: Z- t



  1. DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
  2. DEA:EMA(DIF,9);
  3. MACD:(DIF-DEA)*2,COLORSTICK;
  4. JC:=DEA-DIF;
  5. AA:=BARSLAST(JC<0);
  6. BB:=BARSLAST(JC>0);
  7. T:IFELSE(AA>BB,AA,BB),NODRAW;
  8. 绿柱面积:1000*IFELSE(MACD<0,SUM(MACD,BARSLAST(JC<0)),0),NODRAW;
  9. 红柱面积:1000*IFELSE(MACD>0,SUM(MACD,BARSLAST(JC>0)),0),NODRAW;
  10. U:IFELSE(AA>BB,ABS(绿柱面积)/AA,红柱面积/BB),NODRAW;
  11. A1:=IFELSE(MACD<0,LLV(绿柱面积,BARSLAST(JC<0)),0);
  12. A2:=IFELSE(MACD>0,HHV(红柱面积,BARSLAST(JC>0)),0);
  13. DRAWNUMBER(CROSS(DEA,DIF),0+1.2/10000,REF(A2,1),2,COLORRED);
  14. DRAWNUMBER(CROSS(DIF,DEA),0-1.2/10000,REF(A1,1),2,COLORGREEN);
复制代码






回复

使用道具 举报

您需要登录后才可以回帖 登录 | 免费注册
电话咨询: 135xxxxxxx
关注微信