找回密码
 免费注册

[文华源码] 文华均线与MACD结合交易模型源码[文华财经公式]

0
回复
127
查看
[复制链接]

53

主题

55

帖子

315

积分

超级版主

Rank: 8Rank: 8

积分
315
来源: 2020-5-31 15:23:56 显示全部楼层 |阅读模式
本帖最后由 张咏 于 2020-5-31 15:28 编辑

[文华源码] 文华均线与MACD结合交易模型源码[文华财经公式]
  1. SHORT:=12;//参数
  2. LONG:=26;//参数
  3. M:=9;//参数
  4. A:=MA(CLOSE,20);
  5. MA1:=MA(CLOSE,1);
  6. VAR11:=(2*CLOSE+OPEN+HIGH+LOW)/5;
  7. M8:=SUM(VAR11*VOL,8)/SUM(VOL,8);
  8. SH:=LLV(M8, 8)+MA1*0.118;
  9. DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
  10. DEA:=MA(DIFF,M);
  11. MM:=MA1-A;
  12. MD:=DIFF-DEA;
  13. QF1:=IFELSE(REF(MM,2)<REF(MM,1)&&REF(MM,1)>MM,2,0);
  14. MF1:=IFELSE(REF(MD,2)<REF(MD,1)&&REF(MD,1)>MD,2,0);
  15. QF1=1&&MF1=1,BK;
  16. QF1=2&&MF1=2,SK;
  17. HIGH>=BKPRICE+13,SP;
  18. LOW<=BKPRICE-8,SP;
  19. LOW<=SKPRICE-13,BP;
  20. HIGH>=SKPRICE+8,BP;
  21. AUTOFILTER;//用于MYTRADE的话,后两行去掉
  22. AUTOMERGE;
复制代码
源码解析:
  1. SHORT赋值:12
  2. 参数LONG赋值:26
  3. 参数M赋值:9
  4. 参数A赋值:收盘价的20日简单移动平均
  5. MA1赋值:收盘价的1日简单移动平均
  6. VAR11赋值:(2*收盘价+开盘价+最高价+最低价)/5
  7. M8赋值:VAR11*成交量(手)的8日累和/成交量(手)的8日累和
  8. SH赋值:8日内M8的最低值+MA1*0.118
  9. DIFF赋值:收盘价的SHORT日指数移动平均-收盘价的LONG日指数移动平均
  10. DEA赋值:DIFF的M日简单移动平均
  11. MM赋值:MA1-A
  12. MD赋值:DIFF-DEA
  13. QF1赋值:IFELSE(2日前的MM<昨日MM并且昨日MM>MM,2,0))
  14. MF1赋值:IFELSE(2日前的MD<昨日MD并且昨日MD>MD,2,0))
  15. QF1=1并且MF1=1,BK
  16. QF1=2并且MF1=2,SK
  17. 最高价>=BKPRICE+13,SP
  18. 最低价<=BKPRICE-8,SP
  19. 最低价<=SKPRICE-13,BP
  20. 最高价>=SKPRICE+8,BP
  21. AUTOFILTER
  22. //用于MYTRADE的话,后两行去掉AUTOMERGE
复制代码



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 免费注册
电话咨询: 135xxxxxxx
关注微信